General > Announcements

CB550 K3 1978 PD46A carbs wont rev above 4500rpm


Hello Fellow Owners/ sufferers,
I have been having a nightmare trying to get my nut and bolt rebuild CB550K3 to run properly. However, I have solved it and wanted to share the solution with you all as I was searching for the answer on this forum and the other SOHC forum. At this point I have to say that I had ultrasonically cleaned the carbs, cleared out the float breather holes (in the brass rod out of the side of each carb), checked all internal petrol and air ways were clear and set the float heights with carbs on their sides at 14.5mm. I have stock exhausts (which are little more free breathing than they should be due to baffle disintegration) and standard air box and filter (which is new at vast expense).
1. The first problem was that I couldn't get it to run on all four cylinders at all until having fired on two for a good few minutes.  It would finally start to behave and in the end fire on all four. The main mystery was that it was 1 and 2 that didn't seem to be firing and that meant it couldn't be ignition as 1 and 4 share points and coil and 2 and 3 share the other one. After trying all sorts and taking off the carbs numerous times I finally realised that the choke flaps weren't quite closing on full choke on 1 and 2. They had a gap of about 1mm at the bottom and I thought that would be OK but it wasn't. Readjusting the flaps by loosening the two screws holding them to the bar and then retightening them with he flap fully closed allowed them to fully close with no gap at all. This completely solved the cold starting problem. I think its because the choke doesn't simply just block the air from coming in. I think it allows a vacuum somewhere in the carb to build up and draw more petrol through and with a 1mm gap this vacuum is not building up so not giving the richer mixture to 1 and 2 in this case.

2. The second problem was that the bike would not rev past about 4500rpm. Up to this point in the rev range the bike behaved beautifully. I had originally replaced all jets (apart from the one you have to pull out manually), tubes and needles with the Keyster carb kits. In an attempt to solve problem No.1 I had replaced the Keyster needles with the original Honda ones which had no effect on problem No.1. I now had Keyster main jets (90) and emulsifier tubes with the Original Honda needles (set to the middle position). In an attempt to solve the 'not revving out' problem I decided to try taking out the air filter. It ran a lot worse but basically behaved the in the same way. So I reckoned the bike was running lean even with the air filter installed. I didn't do a plug chop at this point which may have confirmed my suspicions. Anyway, having read lots of different opinions about the Keyster kits I decided to try to measure the size of the Keyster main jet and compare it to the Honda original using a copper multicore wire that I twisted to be 0.9mm across, copper being softer than the brass jet. Note that a 90 jet has a orifice 0.9mm and a 100 jet has an orifice of 1mm etc. I have to say the Keyster was a tad tighter than the original Honda meaning it may have been marginally smaller. Was this significant? I'm not sure really. Obviously changing jets from 90 to 100 is only a 0.1mm change so maybe this difference in feel of the friction between wire and jet is a significant difference. The jury is still out on that one. However, when I came to compare the emulsifier tube from the Keyster kit to the Honda one there was a significant difference in the pattern of holes drilled in the sides of the tube. The original Honda tube has three pairs of holes at the main jet end of the tube, a pair of holes at right angles half way up the tube and a single pair of holes at the top of the tube. The Keyster tube has almost the opposite. It has a single pair of holes at the main jet end of the tube a gap and then 4 pairs of holes at the top half of the tube. There is no pair of holes at right angles half way up the tube. So does any of this matter? Well, I replaced the Keyster main jets and emulsifier tubes with the original Honda ones. The bike now revs out nicely, no hesitation or flat spot at all so problem solved. The moral of the story is keep your old jets, tubes etc. until you know the new stuff you're replacing it with is OK. I have to say while some have had no problem with Keyster kits I would not use them again. This has taken a very long time and a lot of frustration to solve. I hope this helps someone in the future.

Welcome to the forum Brocky2.

Good that you've got a solution to your problem with it  now up and running competently. They, PD carbs, are very finely metered with even tiny impairment or not quantified parts likely to give variable effects.

Generally we do on here advocate using original "brass" components in carbs if they are in good order. Various problems have been experienced when changing to aftermarket (not always, but significant number) with something new owners expected to be at parity for accurate reproduction.

At least good weather to get out and about and enjoy it now  :)

Hi, and welcome to forum. I am also a 550k3 owner / sufferer 🤭 with same carbs. Very interesting to hear your plight and successful outcome. The only alteration I have made with mine is to increase pilots from 42 to 45, a very worthwhile mod to help cold starting. I have also installed Keyster refurb kit. And noticed the difference with hole pattern in emulsion tubes when I installed them. I still have that midrange hesitation but seems to be OK beyond the 4000/4500 mark. Maybe in the winter I will try the old brassware in the carbs and see ow that goes. Getting quite good at removing and replacing carbs now. 🤭🤭

McCabe-Thiele (Ted):
Very interesting and informative read.
In my head I can't understand how the different hole layout affects the mixture but accept it does- I have also wondered if orientation of the tube affects things

Welcome and thanks for  a top write up, glad you e sorted it and taken the time to tell us all what you’ve been up to and how you’ve done it to overcome the issue

Sent from my iPhone using Tapatalk


[0] Message Index

Go to full version